forked from Fediversity/Fediversity
This setup is greatly inspired by the one used for [0], although with notable modifications, such as: - a SASS preprocessor and CSS compressor - more streamlined NixOS integration tests - cleaned up service configuration - a few notes on how to do things better in the future [0]: https://github.com/Nix-Security-WG/nix-security-tracker/ Apart from cloning the Nix setup, there were additional steps: - Create an empty `src` directory, since the package requires it - In the development shell, run `django-admin startproject panel src` Note that while you can already do ```bash manage migrate manage runserver ``` the NixOS integration tests will fail, since `settings.py` needs careful massaging to expose knobs that can be turned from our systemd wrapper. The required changes are introduced in the next commit to make them observable. Noteworthy related work: - https://github.com/sephii/django.nix Rather mature setup with a clean interface, uses Caddy as reverse proxy. - https://git.dgnum.eu/mdebray/djangonix A work-in-progress attempt to capture more moving parts through the module system, in particular secrets. - https://github.com/DavHau/django-nixos Out of date and somewhat simplistic, but serves as a reasonable example for what can be done I chose the variant I'm intimately familiar with in order to be able to pass on knowledge or help with maintenance. But for the future I strongly recommend picking the good bits from the other implementations that control complexity in static configuration parts through Nix expressions.
57 lines
1.2 KiB
Nix
57 lines
1.2 KiB
Nix
{
|
|
lib,
|
|
buildPythonPackage,
|
|
setuptools,
|
|
django_4,
|
|
django-compressor,
|
|
django-libsass,
|
|
dj-database-url,
|
|
}:
|
|
let
|
|
src =
|
|
with lib.fileset;
|
|
toSource {
|
|
root = ../src;
|
|
fileset = intersection (gitTracked ../../.) ../src;
|
|
};
|
|
pyproject = with lib; fromTOML pyproject-toml;
|
|
# TODO: define this globally
|
|
name = "panel";
|
|
# TODO: we may want this in a file so it's easier to read statically
|
|
version = "0.0.0";
|
|
pyproject-toml = ''
|
|
[project]
|
|
name = "Fediversity-Panel"
|
|
version = "${version}"
|
|
|
|
[tool.setuptools]
|
|
packages = [ "${name}" ]
|
|
include-package-data = true
|
|
'';
|
|
in
|
|
buildPythonPackage {
|
|
pname = name;
|
|
inherit (pyproject.project) version;
|
|
pyproject = true;
|
|
inherit src;
|
|
|
|
preBuild = ''
|
|
echo "recursive-include ${name} *" > MANIFEST.in
|
|
cp ${builtins.toFile "source" pyproject-toml} pyproject.toml
|
|
'';
|
|
|
|
propagatedBuildInputs = [
|
|
setuptools
|
|
django_4
|
|
django-compressor
|
|
django-libsass
|
|
dj-database-url
|
|
];
|
|
|
|
postInstall = ''
|
|
mkdir -p $out/bin
|
|
cp -v ${src}/manage.py $out/bin/manage.py
|
|
chmod +x $out/bin/manage.py
|
|
wrapProgram $out/bin/manage.py --prefix PYTHONPATH : "$PYTHONPATH"
|
|
'';
|
|
}
|