forked from Fediversity/Fediversity
Valentin Gagarin
c6cc92f5dc
git-subtree-dir: services git-subtree-mainline:e41e0daa82
git-subtree-split:a13b1e9372
37 lines
700 B
Nix
37 lines
700 B
Nix
{ ... }:
|
|
{
|
|
disko.devices.disk.main = {
|
|
device = "/dev/sda";
|
|
type = "disk";
|
|
content = {
|
|
type = "gpt";
|
|
partitions = {
|
|
MBR = {
|
|
priority = 0;
|
|
size = "1M";
|
|
type = "EF02";
|
|
};
|
|
ESP = {
|
|
priority = 1;
|
|
size = "500M";
|
|
type = "EF00";
|
|
content = {
|
|
type = "filesystem";
|
|
format = "vfat";
|
|
mountpoint = "/boot";
|
|
};
|
|
};
|
|
root = {
|
|
priority = 2;
|
|
size = "100%";
|
|
content = {
|
|
type = "filesystem";
|
|
format = "ext4";
|
|
mountpoint = "/";
|
|
};
|
|
};
|
|
};
|
|
};
|
|
};
|
|
}
|