forked from Fediversity/Fediversity
Valentin Gagarin
83b1c9ac3b
git-subtree-dir: infra git-subtree-mainline:9d6a0f0a33
git-subtree-split:cf086dc3e8
25 lines
589 B
Nix
25 lines
589 B
Nix
{
|
|
inputs = {
|
|
nixpkgs.url = "github:nixos/nixpkgs/nixos-24.05";
|
|
snf.url = "git+https://git.fediversity.eu/fediversity/simple-nixos-fediverse.git";
|
|
};
|
|
|
|
outputs = { self, nixpkgs, snf }:
|
|
let
|
|
vmName = "vm02186";
|
|
|
|
in {
|
|
nixosConfigurations.${vmName} = nixpkgs.lib.nixosSystem {
|
|
system = "x86_64-linux";
|
|
|
|
modules = [
|
|
./procolix-configuration.nix
|
|
./hardware-configuration.nix
|
|
./gitea-runner.nix
|
|
];
|
|
};
|
|
|
|
isoInstallers.${vmName} = snf.mkInstaller nixpkgs self.nixosConfigurations.${vmName};
|
|
};
|
|
}
|